Language:
Knowledgebase
How do I clear my Internet browser's cache?
24 December 2008 03:26 PM

I've had a variety of problems when I try to log in or load certain pages in the site I am using. What can I do to correct this?

If you close your browser without logging out or use more than one account in the same browser, conflicting sign-in information (cookies) may be stored in the browser.

Deleting the temporary Internet files and cookies that have been stored by your browser commonly corrects these problems. Please complete the instructions below for the browser you are using.

If you do not know what version you are using, open your browser and click Help > About [browser name] to see your version number.

Internet Explorer 11
Internet Explorer 9 or 10
Internet Explorer 8
Internet Explorer 7
Chrome
Safari 6
Safari 5 or Earlier
Firefox

Internet Explorer 11

  1. Open Internet Explorer 11.
  2. On the very right-hand side of the browser, click on the gear icon, also called the Tools icon, followed by Safety, and finally Delete browsing history...
    Note: If you have the Menu bar enabled, you can instead click Tools and then Delete browsing history....
  3. In the Delete Browsing History window that appears, uncheck all options except the one labeled Temporary Internet files and website files.
  4. Click the Delete button.
  5. The Delete Browsing History window will disappear and you may notice your mouse icon go busy for a few moments.

    Note: This may take a few minutes to process. Please wait for the files to delete before you continue. As soon as your cursor returns to normal, or you notice the "fished deleting" message at the bottom of the screen, consider your temporary Internet files deleted.

Back to top >>

Internet Explorer 9 or 10

  1. Close all Internet Explorer windows.
  2. Open a new Internet Explorer session and click ToolsInternet Options. (If you do not see "Tools," press the Alt key to show the menu bar.)
  3. In the Internet Options window, click the Delete... button in the Browsing history section.
  4. In the Delete Browsing History window, check "Temporary Internet Files" and "Cookies."  If you have saved any Pearson sites as Favorites, uncheck "Preserve Favorites website data."
  5. Click Delete.

    Note: This may take a few minutes to process. Please wait for the files to delete before you continue.

Back to top >>

Internet Explorer 8

Note: Internet Explorer 8 is no longer supported by some Pearson websites. Please check the system requirements of the web site you'd like to use to be sure you're using a compatible browser.

  1. Close all Internet Explorer windows.
  2. Open a new Internet Explorer session and click ToolsInternet Options. (If you do not see "Tools," press the Alt key to show the menu bar.)
  3. In the Internet Options window, click the Delete... button in the Browsing history section.
  4. In the Delete Browsing History window, check "Temporary Internet Files" and "Cookies." If you have saved any Pearson sites as Favorites, uncheck "Preserve Favorites website data."
  5. Click Delete.

    Note: This may take a few minutes to process. Please wait for the files to delete before you continue.

Back to top >>

Internet Explorer 7

Note: Internet Explorer 7 is no longer supported by some Pearson websites. Please check the system requirements of the web site you'd like to use to be sure you're using a compatible browser.

  1. Close all Internet Explorer windows.
  2. Open a new Internet Explorer session and click ToolsDelete Browsing History....
  3. In the Delete Browsing History window, click Delete files... then click Yes.

    Note: This may take a few minutes to process. Please wait for the files to delete before you continue.

  4. Next, click Delete cookies... then click Yes.
  5. When the cookies have finished deleting, click Close.

Back to top >>

Chrome

In recent versions:

  1. Close all Chrome windows.
  2. Open a new Chrome session and click the Chrome menu (Image) on the browser toolbar.
  3. Click Tools.
  4. Click Clear browsing data.
  5. In the dialog that appears, select the following checkboxes:
    • Empty the cache
    • Delete cookies and other site and plug-in data
  6. Use the menu at the top, select "beginning of time".
  7. Click Clear browsing data.

    Note: This may take a few minutes to process. Please wait for the files to delete before you continue.

  8. Click the "x" to the right of the Settings tab to close it.

In older versions:

  1. Close all Chrome windows.
  2. Open a new Chrome session and click the wrench icon (wrench icon).
  3. Click Settings (or in older versions, Options).
  4. Scroll down to the Privacy heading (you may need to click Show advanced settings..., or in older versions, Under the Hood).
  5. In the Privacy section, click Content settings...
  6. In the Cookies section, click All cookies and site data...
  7. Click Remove all.

    Note: This may take a few minutes to process. Please wait for the files to delete before you continue.

  8. Click the "x" to the right of the Settings - Cookies and site data tab to close it.

Back to top >>

Safari

  1. Close all Safari windows.
  2. Open a new Safari session.
  3. Open the Preferences window.
    In Mac OS X: Click Safari > Preferences.
    In Windows: Click Edit or Settings (Image) > Preferences.
  4. In the Preferences window, click Advanced.
  5. Place a check in the box beside "Show Develop menu in menu bar".
  6. Click Develop > Empty Caches.

    Note: This may take a few minutes to process. Please wait for the files to delete before you continue.

  7. Return to the Preferences window and click Privacy.
  8. Click the Remove All Website Data... button.
  9. Click Remove Now.

Back to top >>

Safari 5 or Earlier

  1. Close all Safari windows.
  2. Open a new Safari session.
  3. In Mac OS X: Click Safari > Empty Cache.
    In Windows: Press Ctrl + Alt + E.
  4. Click Empty.

    Note: This may take a few minutes to process. Please wait for the files to delete before you continue.

  5. Open the Preferences window.
    In Mac OS X: Click Safari > Preferences.
    In Windows: Click Edit or Settings (Image) > Preferences.

In Safari 5.1 or later:

  1. In the Preferences window, click Privacy.
  2. Click the Remove All Website Data... button.
  3. Click Remove Now.

In Safari 5.0 or earlier:

  1. In the Preferences window, click Security.
  2. Click the Show Cookies button.
  3. Click the Remove All button, then click Done.

Back to top >>

Firefox

  1. Close all Firefox windows.
  2. Open a new Firefox session.
  3. Open the Options/Preferences window.
    In Windows: Click Tools > Options. (If you do not see "Tools," press the Alt key to show the menu bar.)
    In Mac OS X: Click Safari > Preferences.
  4. Click the Advanced panel.
  5. Click the Network tab.
  6. In the Cached Web Content section, click Clear Now.

    Note: This may take a few minutes to process. Please wait for the files to delete before you continue.

  7. In Windows: Click OK to close the Options window.
    In Mac OS X: Click the red "x" to close the Preferences window.
  8. Click History > Clear Recent History.... (If you do not see "History," press the Alt key to show the menu bar.)
  9. Set "Time range to clear" to Everything.
  10. Click the arrow next to Details to expand the list of history items.
  11. Select Cookies and make sure that other items you want to keep are not selected.
  12. Click Clear Now to clear the cookies and close the Clear Recent History window.

    Note: This may take a few minutes to process. Please wait for the files to delete before you continue.

Back to top >>

(587 vote(s))
Helpful
Not helpful